L Series: Error: "This client model is unsupported by your version of software"

L Series: Error: "This client model is unsupported by your version of software"

Many factors are at play here if you receive this message: 

You have a Legacy Terminal

If you use a L Series Legacy Device (L100, L110, L120, or L200) device, these are outdated, need to be upgraded and because of their age may have little or no support available.  Models L130 and L230 are more recent legacy products and will connect to both vSpace 4 and vSpace 6 only.

We suggest to check out our new line of products and consult your sales representative or authorized partner about updating your product.  You can also check the NComputing Product Lifecycle page in order to identify your product and determine its support status. 

Also, "Classic Versions" like vSpace 6 will be permanently discontinued after June 30th, 2020.  
Please upgrade promptly to our latest platform  vSpace Pro
If you need technical support to guide you on your upgrade, you can contact us here


You have an L300 terminal that is not properly licensed to connect to vSpace Pro.   

If you are using an L300 terminal, the issue may be with licensing compliance
  1. Check the manufacturing date of your device. 
  2. If your terminal is older than January 1, 2015, it is subject to our Compliance Policies
  3. If your terminal happens to need a license, no problem. You can solvent that joining our AMP subscription program (which will include the license for your device) or you can purchase an "Aged device license".

You have an L300 terminal that is not properly licensed to connect to vSpace Pro.   

  1. Make sure that your AMP subscription is compliant. Login to NComputing.com with your credentials, click on the Management Portal tab, choose My vSpace Installations and check on that your account is IN COMPLIANCE.  If your account bears the sign NOT IN COMPLIANCE, you will be able to tell the discrepancy of licenses and purchase the difference.
  2. Be sure that you have the latest version of vSpace Pro. Previous versions may be unsupported.  

Additional advice

Be sure you are using the right operating system with your terminal. Check our Product / OS Compatibility Matrix
Contact technical support here


Article #KB082
Last Edited: May 22, 2020

    • Related Articles

    • L Series: Error: "This client's firmware is unsupported by the terminal server software"

      Scope When attempting to connect to an L-series vSpace host on the network, the error appears, and the connection fails. If you use a L Series Legacy Device (L100, L110, L120, or L200) device, these are outdated, need to be upgraded and because of ...
    • L Series: L-230, L-130 and Legacy Devices. About USB Device Support

      If you are using terminals that are not compatible with vSpace Pro 11 or Enterprise edition, likely, these are outdated and need to be upgraded.   You can see our new line of products and consult your sales representative or authorized partner about ...
    • Error - Unsupported Processor Type

      vSpace Pro - When installing vSpace Pro you receive an error message This Installation Package is not supported by this processor type. Contact your product vendor. This error message is displayed when attempting to install vSpace Pro on Win10 32 Bit ...
    • How do I update my vSpace software to the latest version?

      Announcements are usually made to your mailbox, our website and social media when we have new releases.   Typically, in contiguous revisions, vSpace software can be installed on top of the previous version.  However, when the revisions are too far ...
    • vSpace Client License error - Incorrect version of license

      When using vSpace Client to connect to vSpace Pro, you may receive an error similar to the below If you receive this message, you are using a version of vSpace Client that was developed for vSpace 8.x and earlier.  Please contact your System ...