Cannot Connect Devices on Generation 2 HyperV VMs.

Cannot Connect Devices on Generation 2 HyperV VMs.

Cannot Connect Devices on Generation 2 HyperV VMs. 

This Article is for customers running into a restricted connection issue we have had reported when using Gen 2 VMs on HyperV.

A workaround that may resolve the issue is to disable Secure Boot on the VM that has the vSpace Server Software installed.


We have not had reports from customers of this issue with the Gen 1 VMs.

Please contact NComputing support with further questions.


    • Related Articles

    • Virtual Machine deployment tips for vSpace Pro deployment

      vSpace Pro can be deployed on a Virtual Machine environment, just the same as a Bare Metal (hardware) environment.  However, here are some tips we have for you if you choose to deploy a VM with vSpace.   It is assumed that you are comfortable and ...
    • NoTouch Center Appliance Install on a HyperV VM

      This article is for anyone wanting to install the NComputing NoTouch Center Appliance specifically on Microsoft HyperV 2016 Currently there are not screen shots but I will make sure and be descriptive and will reference relevant links mentioned.  ...
    • vSpace Pro Installation - Tips, References and Process Detail

      Published The following article is a detailed process and tips for installing our vSpace Pro platform (vSpace Pro LTS, vSpace Pro Enterprise Edition).    As an additional supplement, this article will deal with all other aspects of Pre-Deployment and ...
    • NComputing Deployment Checklist for L, M, MX, RX Series thin clients and Client Pro

      Summary This document is intended to provide a detailed overview of the three stages of an L-series, M-series, and vSpace Client deployment: • Pre-deployment • Host Deployment • NComputing Product Installation. Below you'll find a consolidated list ...
    • Smart Card Reader Support in vSpace Pro

      Enhanced Smart Card Reader Support: Extended smart card support for RX300 and vSpace Pro Client for Windows is now an included feature starting with vSpace Pro version starting in 11.2.0 and higher versions. If your organization requires smart cards ...