Windows: Resolving Windows startup issues after installing KB2644615 LEGACY

Windows: Resolving Windows startup issues after installing KB2644615 LEGACY


"Classic Versions" like vSpace 4 have no more support and will be permanently discontinued after June 30th, 2020.  Please upgrade your vSpace version to our latest platform vSpace Pro

If you are using version 4 because of terminals that are not compatible with vSpace Pro 11 or Enterprise Edition, likely, these are also outdated and need to be upgraded.  You can see our new line of products and consult your sales representative or authorized partner about updating your product.    

If you need technical support to guide you on your upgrade, you can contact us here


Symptom

The installation of Windows update KB2644615 on a system already running vSpace 4.9.5.11 can cause a failure to boot into Windows correctly. Specifically, the system will typically stop at the Windows 2003 or XP splash screen.

NOTE: This issue appears to only affect Server 2003 and Windows XP hosts running vSpace 4 for the L-series.

Cause

KB2644615 makes certain changes to the host environment that need to be completed without the presence of vSpace. Once these changes are made, vSpace can be reinstalled on top of this update and will continue to function normally. The failure to boot properly is the result of an order of install issue, not a flat incompatibility.

Solution 1: KB2644615 has already been installed

If KB2644615 has already been installed on the vSpace 4 host and the host is now failing to boot properly, you can restore functionality as follows:

  1. From the host, boot into “Safe Mode” (tap F8 during the boot process).
  2. In Safe Mode, proceed to Add/Remove programs (located under Control Panel).
  3. Ensure that the “show updates” checkbox is checked in the Add/Remove programs window, then locate and uninstall KB2644615. (All Windows Updates will be grouped together within the Add/Remove programs list.)
  4. Reboot the host to complete the uninstall process, this time returning to Windows in normal mode (Safe Mode should no longer needed at this point).
  5. Once in Windows, uninstall vSpace using the uninstall utility in the Start->All Programs->vSpace folder or through the Add/Remove programs utility. Reboot the host to complete the uninstall process.
  6. Once you have returned to the desktop, run the Windows Update utility and install KB2644615. Reboot the host to complete the Windows Update process.
  7. Once KB2644615 has been installed, reinstall vSpace 4. (the latest vSpace software can be downloaded at https://www.ncomputing.com/en/support/software)

Solution 2: KB2644615 has not been installed yet

If KB2644615 is scheduled for install but has not yet been installed on the vSpace 4 host, proceed as follows to avoid a potential conflict:

  1. Make sure that all client sessions have been closed, then go to the host session and uninstall vSpace 4.
  2. Perform the Windows update as normal including the installation of KB2644615.
  3. Once the system has rebooted, reinstall vSpace 4. (the latest vSpace software can be downloaded at https://www.ncomputing.com/en/support/software)


Article #KB077
Last Edited: May 19, 2020